# How to install/configure via Docker?

**URL:** <https://kopia.discourse.group/t/how-to-install-configure-via-docker/1065>\
**Category:** Support\
**Created:** [April 27, 2022, 12:26am UTC](https://kopia.discourse.group/t/how-to-install-configure-via-docker/1065 "2022-04-27T00:26:53Z")\
**Posts on this page:** 12\
**Page:** 1

<div class="post-metadata">

**Author:** ![tiger2983](https://avatars.discourse-cdn.com/v4/letter/t/a698b9/32.png) [@tiger2983](https://kopia.discourse.group/u/tiger2983)\
**Post date:** [April 27, 2022, 12:26am UTC](https://kopia.discourse.group/t/how-to-install-configure-via-docker/1065/1 "2022-04-27T00:26:53Z")

</div>

How do I install/configure the Kopia Docker container?

I got this far:

[Kopia Docker Container Info](https://pastebin.com/raw/R81HqnQD)

Log:

```auto
# docker start kopia -i
usage: kopia [<flags>] <command> [<args> ...]

Kopia - Fast And Secure Open-Source Backup
...

```

Troubleshooting ideas?

---

<div class="post-metadata">

**Author:** ![iBackup](https://yyz2.discourse-cdn.com/free1/user_avatar/kopia.discourse.group/ibackup/32/355_2.png) [@iBackup](https://kopia.discourse.group/u/iBackup)\
**Post date:** [April 27, 2022, 6:54am UTC](https://kopia.discourse.group/t/how-to-install-configure-via-docker/1065/2 "2022-04-27T06:54:23Z")

</div>

> [@tiger2983](#):
>
> How do I install/configure the Kopia Docker container?

Take a look here: [Download & Installation | Kopia](https://kopia.io/docs/installation/#docker-images)

---

<div class="post-metadata">

**Author:** ![tiger2983](https://avatars.discourse-cdn.com/v4/letter/t/a698b9/32.png) [@tiger2983](https://kopia.discourse.group/u/tiger2983)\
**Post date:** [April 27, 2022, 5:06pm UTC](https://kopia.discourse.group/t/how-to-install-configure-via-docker/1065/3 "2022-04-27T17:06:45Z")

</div>

I followed the docker install steps in the documentation…

```auto
root # docker pull kopia/kopia
Using default tag: latest
latest: Pulling from kopia/kopia
Digest: sha256:47a1a799f045d625be96509d6c9c0b93cb02ee0eb9d22549a0dea0f94089c6e5
Status: Image is up to date for kopia/kopia:latest
docker.io/kopia/kopia:latest

root # docker run -e KOPIA_PASSWORD=password \
> -v /path/to/config/dir:/app/config \
> -v /path/to/cache/dir:/app/cache \
> -v ~/.config/rclone:/app/rclone \
> kopia/kopia snapshot list
ERROR open repository: repository is not connected. See https://kopia.io/docs/repositories/

```

It is my understanding this would give me a container of the Kopia server, and I can do the remaining configurations through Kopia’s web UI.

---

<div class="post-metadata">

**Author:** ![Matt](https://avatars.discourse-cdn.com/v4/letter/m/a6a055/32.png) [@Matt](https://kopia.discourse.group/u/Matt)\
**Post date:** [May 6, 2022, 5:48am UTC](https://kopia.discourse.group/t/how-to-install-configure-via-docker/1065/4 "2022-05-06T05:48:57Z")

</div>

> kopia/kopia snapshot list

This command has asked Kopia to list snapshots, so you’re being told that there is no repository connected – not a surprise since it’s your first time running!

TBH, I am not sure how feature-rich the webUI is. It may, or may not give you all of the control of setting up a repo you need. It’d be my advice that you consider setting up the repo via the CLI. However, to answer your question, you need to change the command I listed above to run the webUI:

`kopia/kopia:testing server --insecure --address=0.0.0.0:51515 --server-username=kopia --server-password=kopia --override-hostname=kopia-server`

So, I am using the testing branch (which can be removed if you want stable), then we invoke the webUI with ‘server’, the ‘insecure’ flag allows the server to operate without TLS, the ‘address’ field is set to listen on all IP addresses, and we then set web username and password. The final field allows a consistent hostname for your backups as each time you spawn a Docker container, you’ll have differing names.

The above should get you up & running.

However, as I said at the beginning, you should consider setting the repo via the CLI.

Just start with `kopia/kopia repository create` and follow the [instructions](https://kopia.io/docs/repositories/).

---

<div class="post-metadata">

**Author:** ![tiger2983](https://avatars.discourse-cdn.com/v4/letter/t/a698b9/32.png) [@tiger2983](https://kopia.discourse.group/u/tiger2983)\
**Post date:** [May 6, 2022, 3:34pm UTC](https://kopia.discourse.group/t/how-to-install-configure-via-docker/1065/5 "2022-05-06T15:34:30Z")

</div>

Thanks for the reply. I finally got the container up and running a few days ago by not following the published docker instructions (removed the line “kopia/kopia snapshot list” like you mentioned).

Things going good, and I was able to create my first repository and had my first backup.

Now, for whatever reason, my [container will no longer run](https://kopia.discourse.group/t/unable-to-initialize-repository-error-connecting-to-repository-unable-to-list-sources-unable-to-find-manifest/1089). I also created a 2nd container, but cannot access the repository.

I’m also not sure I can get to a command prompt with the 2nd container because there’s no “sh” for the docker container.

Frustrated because I have a data backup, but cannot access the backup!

---

<div class="post-metadata">

**Author:** ![iBackup](https://yyz2.discourse-cdn.com/free1/user_avatar/kopia.discourse.group/ibackup/32/355_2.png) [@iBackup](https://kopia.discourse.group/u/iBackup)\
**Post date:** [May 6, 2022, 7:42pm UTC](https://kopia.discourse.group/t/how-to-install-configure-via-docker/1065/6 "2022-05-06T19:42:30Z")

</div>

Why do you complicated your live by trying to run kopia from docker ?  
Is it a public host that you want to secure with docker, or you have a bunch programs that you don’t trust and want to isolated them from each other?

Just use kopia directly, it is just one single executable file

---

<div class="post-metadata">

**Author:** ![tiger2983](https://avatars.discourse-cdn.com/v4/letter/t/a698b9/32.png) [@tiger2983](https://kopia.discourse.group/u/tiger2983)\
**Post date:** [May 6, 2022, 8:36pm UTC](https://kopia.discourse.group/t/how-to-install-configure-via-docker/1065/7 "2022-05-06T20:36:52Z")

</div>

> [@iBackup](#):
>
> Why do you complicated your live by trying to run kopia from docker ?

I use Kopia Docker with Unraid NAS.

---

<div class="post-metadata">

**Author:** ![iBackup](https://yyz2.discourse-cdn.com/free1/user_avatar/kopia.discourse.group/ibackup/32/355_2.png) [@iBackup](https://kopia.discourse.group/u/iBackup)\
**Post date:** [May 6, 2022, 9:54pm UTC](https://kopia.discourse.group/t/how-to-install-configure-via-docker/1065/8 "2022-05-06T21:54:06Z")

</div>

> [@tiger2983](#):
>
> I use Kopia Docker with Unraid NAS.

There is “CA User Scripts” in the community applications, that you can use to run programs directly, without messing with docker. One of the best thing in kopia is that it is single executable file, so put it in some bash script and run without overhead.

---

<div class="post-metadata">

**Author:** ![Matt](https://avatars.discourse-cdn.com/v4/letter/m/a6a055/32.png) [@Matt](https://kopia.discourse.group/u/Matt)\
**Post date:** [May 7, 2022, 3:54am UTC](https://kopia.discourse.group/t/how-to-install-configure-via-docker/1065/9 "2022-05-07T03:54:38Z")

</div>

I’m running my kopia instance in Docker and it’s working perfectly. What errors are you getting? Can you post the output of `snapshot list` ?

---

<div class="post-metadata">

**Author:** ![tiger2983](https://avatars.discourse-cdn.com/v4/letter/t/a698b9/32.png) [@tiger2983](https://kopia.discourse.group/u/tiger2983)\
**Post date:** [May 7, 2022, 4:14am UTC](https://kopia.discourse.group/t/how-to-install-configure-via-docker/1065/10 "2022-05-07T04:14:51Z")

</div>

> [@Matt](#):
>
> snapshot list

I was eventually able to get the Docker to run, but not having a different issue (after successfully creating my first backup):

> [@Unable to initialize repository: error connecting to repository: unable to list sources: unable to find manifest](https://kopia.discourse.group/t/unable-to-initialize-repository-error-connecting-to-repository-unable-to-list-sources-unable-to-find-manifest/1089):
>
> When trying to start Kopia Docker Container, I receive this error message in the log: e[31mERRORe[0m unable to initialize repository: unable to initialize repository: error connecting to repository: unable to list sources: unable to find manifest entries: unable to load manifest contents: error loading manifest content: invalid checksum at q1ff9583be62c7bacd6b47fb3b9436709-s5f0fb1f4a889412e10f offset 14049 length 527/527: decrypt: unable to decrypt content: cipher: message authentication faile…

This backup is particularly important right now because I encountered some sort of “bitrot” on one of my files, and I want to check my backup to see if the bitrot happened before or after a certain date.

---

<div class="post-metadata">

**Author:** ![mptpro](https://yyz2.discourse-cdn.com/free1/user_avatar/kopia.discourse.group/mptpro/32/645_2.png) [@mptpro](https://kopia.discourse.group/u/mptpro)\
**Post date:** [March 21, 2023, 2:00am UTC](https://kopia.discourse.group/t/how-to-install-configure-via-docker/1065/11 "2023-03-21T02:00:19Z")

</div>

> [@iBackup](#):
>
> Why do you complicated your live by trying to run kopia from docker ?

In my case two reasons:

1. I have a program (“Homepage”) that let’s me view all my Docker Containers and their status (running, health, not running, not healthy etc) remotely. It also gives me specific details of Kopia via a custom widget:  
 ![ksnip_20230320-190249](https://global.discourse-cdn.com/free1/uploads/kopia/original/1X/d537492ac724e0b5dc34097ae36938a16f0b91fa.png)

2. The Docker version of Kopia has a web server that lets me control it remotely. I’m not sure the GUI version for Linux does that. I’m running it on a headless machine.

---

<div class="post-metadata">

**Author:** ![budy](https://yyz2.discourse-cdn.com/free1/user_avatar/kopia.discourse.group/budy/32/38_2.png) [@budy](https://kopia.discourse.group/u/budy)\
**Post date:** [March 23, 2023, 9:41am UTC](https://kopia.discourse.group/t/how-to-install-configure-via-docker/1065/12 "2023-03-23T09:41:26Z")

</div>

Then simply run an instance of Kopia Server on your headless client. This one does also run a web UI, where you can check up on your snapshots and even download single files.
