# How to run "rclone config reconnect" in Kopia Docker container?

**URL:** <https://kopia.discourse.group/t/how-to-run-rclone-config-reconnect-in-kopia-docker-container/4161>\
**Category:** Support\
**Created:** [June 29, 2025, 5:59pm UTC](https://kopia.discourse.group/t/how-to-run-rclone-config-reconnect-in-kopia-docker-container/4161 "2025-06-29T17:59:46Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![prosumer](https://yyz2.discourse-cdn.com/free1/user_avatar/kopia.discourse.group/prosumer/32/1650_2.png) [@prosumer](https://kopia.discourse.group/u/prosumer)\
**Post date:** [June 29, 2025, 5:59pm UTC](https://kopia.discourse.group/t/how-to-run-rclone-config-reconnect-in-kopia-docker-container/4161/1 "2025-06-29T17:59:46Z")

</div>

About two weeks ago my Kopia backups using `rclone` to OneDrive started failing with an error similar to this one:

```auto
ERROR open repository: unable to open repository: cannot open storage: unable to start rclone: rclone server failed to start: <DATE> <TIME> CRITICAL: Failed to create file system for "<REDACTED>": failed to get root: Get "https://graph.microsoft.com/v1.0/drives/<REDACTED>/root": couldn't fetch token: invalid_grant: maybe token expired? - try refreshing with "rclone config reconnect Mastodon:"

```

Backups have been running fine for months, so automatic refresh did work before.

Since I couldn’t figure out how to run `rclone config reconnect` in the Kopia Docker container (0.20.1) I created a new Rclone connection on my Mac and copied its refresh token to Kopia’s `rclone/rclone.conf` file on the VPS that I’m using the Kopia Docker container on. However, today (about a week later?) I’m running into the same error again, so it’s time I learn how to do this properly…

How can I run `rclone config reconnect` in my Kopia Docker container?

And maybe related, why is automatic refresh failing suddenly? How to fix that?
