# Not able to connect to repo via Kopia tempfile

**URL:** <https://kopia.discourse.group/t/not-able-to-connect-to-repo-via-kopia-tempfile/3561>\
**Category:** General Topics\
**Created:** [December 21, 2024, 3:05am UTC](https://kopia.discourse.group/t/not-able-to-connect-to-repo-via-kopia-tempfile/3561 "2024-12-21T03:05:12Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![Cliff\_Z](https://yyz2.discourse-cdn.com/free1/user_avatar/kopia.discourse.group/cliff_z/32/1239_2.png) [@Cliff\_Z](https://kopia.discourse.group/u/Cliff_Z)\
**Post date:** [December 21, 2024, 3:05am UTC](https://kopia.discourse.group/t/not-able-to-connect-to-repo-via-kopia-tempfile/3561/1 "2024-12-21T03:05:12Z")

</div>

When I try to connect, it gives me the error below. The permission is set correctly on folder. I do have a running Kopia server that is using one config file in the folder. the question is: why it needs to replace the whole folder when repo is going to be connected? I don’t see this behavior on other Kopia servers with the same OS (Windows) and config.

C:\Program Files\KopiaUI\resources\server\>kopia repo connect from-config --file=“C:\Users\admin\AppData\Roaming\kopia\repository12345.config”  
Enter password to open repository:

ERROR error connecting to repository: unable to write config file: error writing file: cannot replace “C:\Users\admin\AppData\Roaming\kopia” with tempfile “C:\Users\admin\AppData\Roaming\kopia2283187054”: replace C:\Users\admin\AppData\Roaming\kopia2283187054 C:\Users\admin\AppData\Roaming\kopia: Access is denied.
