# SFTP blob creation fails with "Operation unsupported" on initial setup

**URL:** <https://kopia.discourse.group/t/sftp-blob-creation-fails-with-operation-unsupported-on-initial-setup/8803>\
**Category:** Support\
**Created:** [February 12, 2026, 6:32am UTC](https://kopia.discourse.group/t/sftp-blob-creation-fails-with-operation-unsupported-on-initial-setup/8803 "2026-02-12T06:32:52Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![tomasv](https://yyz2.discourse-cdn.com/free1/user_avatar/kopia.discourse.group/tomasv/32/1965_2.png) [@tomasv](https://kopia.discourse.group/u/tomasv)\
**Post date:** [February 12, 2026, 6:32am UTC](https://kopia.discourse.group/t/sftp-blob-creation-fails-with-operation-unsupported-on-initial-setup/8803/1 "2026-02-12T06:32:52Z")

</div>

Hi, I am running the latest Kopia v0.22.3 and I am trying to create a new SFTP repository. It always fails on the last step with an error:

_Connect Error: INTERNAL: internal server error: connect error: unable to write blobcfg blob: PutBlob() failed for “kopia.blobcfg”: unable to complete PutBlob(kopia.blobcfg) despite 10 retries: unexpected error renaming file on SFTP: sftp: “Extended request not supported.” (SSH\_FX\_OP\_UNSUPPORTED)_

I see there was a bug previously: [SFTP blob creation fails with "Operation unsupported" on initial setup · Issue #3035 · kopia/kopia · GitHub](https://github.com/kopia/kopia/issues/3035)

Did it come back? The user has all the right permissions (verified via winscp)

Any workaround tips please?
