Full Maintenance fails on MEGA

I’ve recently switched from an S3-compatible service to MEGA. Creating a new repository, configuring rclone and creating Snapshots all went fine. I can access the Snapshots from the Kopia GUI and I’ve also tried to download a few files from the Snapshots, works fine.

But running “Full Maintenance” always fails:

$ kopia maintenance run --full

Running full maintenance...
Looking for active contents...
Looking for unreferenced contents...
GC found 3 unused contents (11.1 KB)
GC found 0 unused contents that are too recent to delete (0 B)
GC found 90455 in-use contents (3.1 GB)
GC found 55 in-use system-contents (43.2 KB)
e[31mERRORe[0m unable to report run: unable to complete PutBlob(kopia.maintenance) despite 10 retries: MOVE kopia.maintenance.f-6313510675506253374: 403
Finished full maintenance.
e[31mERRORe[0m unable to get schedule: error reading schedule blob: unable to complete GetBlob(kopia.maintenance,0,-1) despite 10 retries: error populating output: unexpected EOF

Not sure if this is related, I’ve also tried to run Snapshot Verify, this sometimes works, sometimes fails:

$ kopia snapshot verify --verify-files-percent 1

e[31mERRORe[0m error processing [user@host]:/opt@2024-04-03 04:25:05 CEST/cronicle/logs/archives/2023/09/14/Storage-2023-09-14.log.gz: error reading object ca77dcb9e5d5144372030c09820bf5c9: unable to open object ca77dcb9e5d5144372030c09820bf5c9: unexpected content error: error getting cached content: failed to get blob with ID pe14620e31221cb01e6f210254b24e1a3-sbbe3b181ebe00e59127: unable to complete GetBlob(pe14620e31221cb01e6f210254b24e1a3-sbbe3b181ebe00e59127,2916742,74264) despite 10 retries: ReadStreamRange pe1/462/0e31221cb01e6f210254b24e1a3-sbbe3b181ebe00e59127.f: Get "": dial tcp connect: connection refused
e[31mERRORe[0m error processing [user@host]:/opt@2024-04-03 04:25:05 CEST/cronicle/logs/archives/2024/02/16/Transaction-2024-02-16.log.gz: error reading object a5cad3e463e75ddfaf63953ddbf9ca2d: unable to open object a5cad3e463e75ddfaf63953ddbf9ca2d: unexpected content error: error getting cached content: failed to get blob with ID p3e8ab7a0be1d65ce38ec932bbfa699ec-sbbe3b181ebe00e59127: unable to complete GetBlob(p3e8ab7a0be1d65ce38ec932bbfa699ec-sbbe3b181ebe00e59127,1372341,3662) despite 10 retries: ReadStreamRange p3e/8ab/7a0be1d65ce38ec932bbfa699ec-sbbe3b181ebe00e59127.f: Get "": dial tcp connect: connection refused
Processed 17591 objects.
Finished processing 17606 objects.
e[31mERRORe[0m encountered 2 errors

I’m using:

  • Kopia: v0.16.1
  • rclone: v1.66.0
  • Ubuntu: 20.04
  • Cloud: MEGA

Any hint would be highly appreciated! Thanks a lot in advance!

Do not use rclone and Mega - this is not very reliable mix as you can find on rclone forum. Unfortunately Mega golang library used by rclone is not under active development so unlikely anything will change.

Try native Mega CMD in webdav server mode instead (webdav is supported by kopia natively) - maybe it will perform better.

In addition kopia and rclone integration is experimental - I tried it in the past and results were not good. IMO it is not ready for production use.