Git negate syntax not working?

Hi. New kopia user here!

I’ve been trying to backup only some files on my ~/.config directory. For instance, I have the google-chrome folder there, and there a lot of files and directories inside of it. The only file I’m interested in, however, is google-chrome/Default/Preferences.

So this is the Ignore Rule policy I came up with:

*
!google-chrome/Default/Preferences

However, the filter above doesn’t backup any files on my ~/.config dir whatsoever. Am I misunderstanding something here? Shouldn’t this work?

I’m using the AppImage of Kopia v0.9.0-rc2.

Thanks!

According to the document,

It is not possible to re-include a file if a parent directory of that file is excluded

Because * would exclude google-chrome/, anything inside will always be excluded.