How do i remove basic auth from the gui?

I’m running headless on Ubuntu and i want to stop using basic auth and switch to authentik…

I run Kopia on reboot with this command

/usr/bin/kopia server --insecure --address= --server-username=USER --server-password=PASS

So i figured i just remove the username and password arguments and reboot… but when i do, it’s still using basic auth…

i assume there is a config.yml somewhere, but i’m at a loss as to where it is… Any ideas?

1 Like

Probably kopia config in ~/.config? Delete everything that belons to Kopia and see if it solves your problem.

What you need is /usr/bin/kopia server start --insecure --without-password &

1 Like

“Delete files and see if it works” is a poor solution. At the very least, move the files to a backup location… I’d like to flag this reply for suggested removal. It doesn’t seem like good practice.

@jkowalski thoughts?

Thank you, i’ll give that a shot!