V0.9.3: Backup error? Skipped folder?

I ran a backup using the UI (filesystem repo, fresh repo, first run). I basically backed up a few sources. And there have been no (visible) issues. Except for one source.

In Tasks I can see this snapshot summary for that source

Cached Bytes: 8 GB
Cached Files: 4,186 
Excluded Directories: 4
Processed Bytes: 8 GB
Processed Files: 4,186

This number of excluded directories was a surprise, because I had disabled the default “no cache, temp, …” exclusion.

I tried to find out what directories were excluded, but there does not seem a command for that. So I mounted the snapshot and compared the two with Meld. I could see two differences. One folder was missing, because I had excluded it with an ignore rule (/donotbackup/). But another folder was missing as well: gapps (this folder has one zip file). I am not able to explain why this “gapps” folder is missing.

So I see two potential bugs here:

  • The task summary is wrong (it should be 2 excluded directories instead of 4).

  • A folder was skipped without apparent reason

I found the reason for the gapps folder. So that is not a bug :slight_smile:

But the UI still shows

Excluded Directories: 4

Which seems to be wrong, since only one folder is excluded (as verified by diffing the source and mounted folder).

Unfortunately the log feature (even log-level debug) in Kopia does not show any kind of information about excluded files/folders.

Plase take a look at DESIGN: Logging policies · Issue #1450 · kopia/kopia · GitHub and I’d love to hear your comments on the proposed logging policies.

I replied to