Backup size much larger than source files

I am backing up some files to Onedrive using kopia with rclone repository. And I’ve found that the repo size on Onedrives side balloons really quickly, a folder of 600G locally is about 2T on the repo.

This is the initial snapshot with compression off

Can you do

kopia blob stat
kopia content stats
kopia blob ls

And paste results on some paste service and put the link here.

Since those commands are taking a long time, I might as well add that I tried adding the arguments --vfs-cache-mode=writes as extra args to rclone as recommended for onedrive and this new repo is now undersized compared to source by 10%ish, I think this is due to kopia killing the rclone process while the files in cache are still not completely sync. I think it might be required to use the remote control api to query the status and wait for it to finish before killing rclone.

Also the oversized repo does not list any snapshots despite running the snapshot successfully initially