Disk consumption larger than source

I’ve run into a problem the last few days. Kopia is backing up 24TB of data (as reported by Unraid) to a device that has 40 TB of disk space. This has been working fine for the better part of 6 months. Now for some reason the target 40 TB drive is completely full. I ran “kopia blob gc --advanced-commands=enabled --delete=yes” to clear out any unreferenced blobs and that cleared up several hundred GB. Once the snapshot ran, it filled the drive again. Maintenance refuses to run as there is no free disk space. What is consuming all this extra disk space? Kopia version is 0.15.0.

kopia content stats
Count: 8734042
Total Bytes: 37.7 TB
Total Packed: 37.4 TB (compression 0.7%)
By Method:
  (uncompressed)         count: 6802142 size: 31.9 TB
  pgzip-best-speed       count: 1644280 size: 5.7 TB packed: 5.5 TB compression: 4.8%
  zstd-fastest           count: 287620 size: 1.1 GB packed: 395.5 MB compression: 62.6%
Average: 4.3 MB

        0 between 0 B and 10 B (total 0 B)
     7876 between 10 B and 100 B (total 475.9 KB)
   383017 between 100 B and 1 KB (total 149.3 MB)
   178478 between 1 KB and 10 KB (total 661.8 MB)
   184580 between 10 KB and 100 KB (total 7.1 GB)
   115393 between 100 KB and 1 MB (total 49.3 GB)
  7864698 between 1 MB and 10 MB (total 37.4 TB)
        0 between 10 MB and 100 MB (total 0 B)


How big is your cache? What kind of data is this?

There are three different compressions set. Did you change the compression algorithm?


Cache size appears to be about 17.6 GB. Data is about half video. Virtual machine backups, user data, ect.

As far as I’m aware. I only have one compression algo set. PGZIP-BEST-SPEED is defined in the global policy. I have a second policy for this specific backup job and it inherits it’s compression algo from the global policy.


Bump. Still haven’t found a solution to this.

Do you run full maintenance periodically? It should run automatically every 24h by default but just in case run:

kopia maintenance run --full

You can see maintenance runs history (and other details) by running:

kopia maintenance info

Maintenance fails to run because the disk is full.

Previously I ran maintenance manually after I cleared the unreferenced blobs. Re-ran the backup and it filled the disk immediately.

Maybe it is as simple as enough data changed since your last snapshot run that more space is needed for it than you have.

Snapshots run twice a day. Changes are minor.

Please run kopia diff SNAPSHOTID1 SNAPSHOTID2 to see which changes kopia detects and verify that changes are truely minor.

I would suspect the virtual machine images to add some substantial amount of data.