Difficult to resume backups with large files

I am running kopia cli on windows backing up large vdi files.

Kopia snap C:\virtualbox\vms

If I stop a backup (ctrl z) and start again with the same command the kopia starts scanning from the beginning.

This makes resuming backups more time consuming because it re reads the complete vdi files again instead of resuming.

I am using kopia 8.4
I guess checkpoints are created automatically
The repo has zstd best compression enabled in global policy.

Rehashing files is unavoidable because there is no indication w.r.t which parts of the VM image may have changed.

In most cases Kopia will be able for avoid reuploading and encryption. Currently compression can’t be avoided but in the next version compression will happen after hashing so will also be avoidable.


Thank you for the update :relaxed:

Would using a fixed-length chunk splitter result in any benefit in this scenario?