FTP or SMB with password


I am running Kopia in a container on TrueNAS. I plan to backup to a USB SSD and then “sync-to” the repo from the SSD to Backblaze. I will also probably sync it to an HDD at some point.

The container is running fine. But I couldn’t get mounting the SSD into the container to work. There is an option to mount devices into the container but it doesn’t work, I don’t see any errors or logs regarding this, and I can’t really get support from TrueCharts (who are providing the integration/helm chart) because it is in alpha (or incubator in their terms).

Today I realized I could connect the SSD to my router (FritzBox) which has a NAS feature. It makes the connected storage device available via SMB and FTP. I can access it via SMB and FTP on Windows and Linux. But Kopia doesn’t seem to support FTP, only SFTP. And Kopia also doesn’t seem to support non-anonymous SMB connections. At least it just says it can’t find the SMB path.

For SMB I tried using \\\fritz.nas\MAIN_BACKUP\kopia\test1. This is copied from Windows explorer. Is any other format needed? Or is authenticated SMB just not supported by Kopia.

Sadly I can’t make my router provide it as SFTP or turn off authentication for SMB.

Hi @randombyte-developer,

i am not using TrueNas and therefore can only provide limited help. Have you looked at Using Launch Docker Image | (truenas.com)?

There you can add your mount as a host path volume. On Kopia UI, you then can access the mount easily.


TrueNAS doesn’t support mounting USB drives as normal folders. If that would be possible, I could use hostpath, right. As a workaround I could SSH into TrueNAS and create some script to mount the USB drive after boot. But I would rather use a supported solution.

Actually I might still find my old raspberry pi (32 bit), and use that to provide an sftp server. I would rather go this route than modifying TrueNAS.

As I wrote earlier, I am using a Raspberry 1 B where I have set up an SFTP server and manually mounted the USB drive. The connection from Kopia works and the snapshot is in progress now. This is more of a temporary solution right now, but it works :slight_smile: