"invalid checksum at" reappearing after cleanup and snapshot

I have a remote machine (Source), where I backup from over SFTP with KopiaUI. ~ 600 Gb of photos, docs, and videos.

  1. I’ve tried to restore the backup to a different machine (Destination) over sftp and got a few errors, unable to read data: unexpected content error: invalid checksum at .... decrypt: unable to decrypt content: cipher: message authentication failed. 8 files for this 600Gb backup

  2. I’ve run this command on the destination machine, where I trying to restore the backup: kopia snapshot fix invalid-files --verify-files-percent 100 --commit --config-file <my-config>

  3. Restore on the destination machine again, no errors, with these 8 files missing

  4. Run a snapshot on the source machine

  5. Restore on destination machine: same error with the same files

  6. kopia snapshot fix invalid-files --verify-files-percent 100 --commit --config-file <my-config>. The same files were cleaned just in a different order

Does it mean it is a cache issue on the source machine? Shall I clean it? I keep the source machine for the moment in case more information is needed for troubleshooting

Thank you