Unable to rewrite content - BLOB not found


I’m getting the followin error (when running full maintenance):

unable to rewrite content "0057afef270c3add1bc0b5fa768821f0": unable to get content data and info: error getting cached content: failed to get blob with ID pb867ee1b7e62088719d57e4b405cdb0a-sf76151515556c8a8118: BLOB not found

I know that there are a lot of other topics on this with some suggestions on how to solve it. I’ve tried more or less all of them (as fare as I was able to do it) but nothing worked. Any suggestions? I’m backing up to an external USB-HDD, so no rclone involved.

Wanted to additionally mention, that I’ve tried the following commands (in various order):

kopia blob delete --advanced-commands=enabled pb867ee1b7e62088719d57e4b405cdb0a-sf76151515556c8a8118

kopia blob gc --advanced-commands=enabled --delete=yes

kopia index recover --advanced-commands=enabled --commit

kopia content delete --advanced-commands=enabled 0057afef270c3add1bc0b5fa768821f0

kopia content rewrite --advanced-commands=enabled 0057afef270c3add1bc0b5fa768821f0

kopia snapshot fix invalid-files --verify-files-percent=100 --commit

Nothing worked and whenever I run full maintenance I always get the above mentioned error.

Any suggestions what I can do?

Since you already deleted the blob this might be counterintuitive, but try:

kopia create --force-hash=100 <stuff to snapshot>

This will force kopia to rescan and rehash everything and write out data that doesn’t exist in the repository. This will take time as it will seems as though kopia is performing a first time snapshot, but quicker because there is not much to upload to the repository. kopia should figure out what was originally in pb867ee1b7e62088719d57e4b405cdb0a-sf76151515556c8a8118 and re-upload it with a different blob id and updating indexes. kopia is rewriting the content because the data should still be on your system.

Hi elel, thanks for your support.

I’ve tried

kopia snapshot create --force-hash=100 <stuff to snapshot>

but it didn’t solve the problem.

It might be, that the content is not on my system any more, that’s why I’ve also tried

kopia content delete

but this did also not help.

I don’t understand why a blob-deletion AND a content-deletion does not solve the problem…

It’s possible then that whatever remains in the blob just needs to age out and get dropped from the repository naturally. At that point, kopia should just delete the blob altogether. Speculation on my part however.

Hmmm. Maybe, but to be honest I don’t think that this will happen, because I’ve already tried to delete the blob with
kopia blob delete --advanced-commands=enabled pb867ee1b7e62088719d57e4b405cdb0a-sf76151515556c8a8118
and I also did run
kopia maintenance --safety=none
several times.

Is it somehow pissible to determin (with missing blob) to figures out:

  • in which contents a blob is needed?
  • in which snapshots the contents (or the missing blog) are in?

Then I would think about deleting these snapshots (not sure if this will solve my problem)…

So @samia did you find any way to rewrite the blobs? I’m in a similar predicament.

Hi alejandor,
no, I didn’t find a solution, but the problem “aged out” (as described by elel).

Interesting. I tried to force that with kopia maintenance run --full --safety=none but no luck. A difference in my case is that maintenance is not throwing errors, only snapshot verify is.

Oh well, thanks for the prompt reply.