Unnecessary reupload


For some reason, I tried to snap a subdir of a dir already snapshotted recently. Files are unchanged between the 2 snaps. Kopia started to upload data. I canceled the snap, but it looked like it was uploading everything from scratch. In the logs, I can read messages like: “could not find cache entry for file1”. Mounting the snap of the dir, I can check that file1 is here and is byte for byte identical to the original file.

I could not reproduce that using randomly generated test files in a subdirectory.

Referring to Kopia re-uploads data, zstd is used but always from the same machine.

Is this to be expected? How could I identify the issue if any?


Are you actually seeing network uploads or just the process taking a long time? I suspect the latter and Kopia is just hashing the files again to determine they don’t need to be uploaded.

Because of compression used this will sometimes cause a reupload, though (but this particular case will be fixed in v0.9 thanks to new index format)

I tried again. It’s been uploading data for 20 minutes. I have a very slow link though, about 80ko/s.

kopia snapshot /data/taff --parallel=1
Snapshotting bim@machine:/data/taff ...
 / 1 hashing, 39 hashed (278.1 MB), 0 cached (0 B), uploaded 70.4 MB, estimated 75.7 GB (0.4%) 76h29m5s left