Application Support directory no longer backed up in macOS Sonoma

Hi,

I just realized that since I upgraded to macOS Sonoma the Library/Application Support directory can no longer be accessed by Kopia. I have not changed any settings. Full disk access is still enabled.

Has anyone else seen this behavior and knows how to give Kopia access to the directory again?

If you’re referring to the Application Support folder inside the user’s home - directory, that does work for me. I also verified that there are recent changes, which have been included into the snapshots.

Do you get any error message about that?

Yes, inside the home directory. ~/Library/Application Support.

The error in each of the snapshots of my home directory says:

Library/Application Support: operation not permitted

Try to remove and then grant Kopia full disk access again.

Done. I get the same error.

I don’t think it has anything to do with full disk access. If that was the issue, wouldn’t other folders be affected as well? It feels more like an extra layer of protection for this specific folder. But I don’t understand where that would come from.

Other then the reminders app, which lists Kopia as the only app, which is allowed to access its data inside the Application Support folder, I don’t know of any other.

You should also be getting a warning dialog, if Kopia cannot access some of your data. If that is not the case, your tcc database may be corrupted and you may needs to check it using the terminal.

What is a tcc database and how can I check it?

I get the same error. The whole folder ~/Application Support/ is not backed up with the message “operation not permitted”. It is due to the presence of the folder com.apple.LaunchServicesTemplateApp.dv inside ~/Application Support/.

I read on various forum that this folder is created by Apple when someone creates a Web app from inside Safari (icon Export … Add to the Dock).

It is not a problem to not backup this small folder. The big problem is that the whole ~/Application support/ is not backed up. In my case it contains more 20 GB of emails!

Does someone have a solution?

Did you enable full disk access for Kopia?

Of course! In fact, my backup was running correctly until recently. I read on the Internet that this is due to the creation of a Web app in Safari and I did it more or less at the same time I realised I had a problem with Kopia.

The specific folder com.apple.LaunchServicesTemplateApp.dv is locked by macOS and no-one can modify or delete it. The solution would be to skip it when it is declared in the Kopia policy. This is what I made but it did not prevent Kopia to stop backing up the whole parent folder.