Before/after-snapshot-root action logs

I`m trying to setup a before/after-snapshot-root action with no luck: my shell script that’s referenced in the before action fails with an error (Error: upload error: exit status 1) but I cannot find any logs in Kopia that shed the light on the error.
The failed task in the Tasks tab shows only that the before action was called:

19:38:45.166 running action before-snapshot-root on /var/lib/portainer/config_backup policy.ActionCommand{Command:"", Arguments:[]string(nil), Script:"/home/kopia/scripts/portainer_backup_config.sh param1 param2", TimeoutSeconds:60, Mode:"essential"}

and that’s all, i.e. no error output here.
The Kopia logs (in a configured folder) contain only the same ‘1’ error:

ERROR kopia/server snapshot error: snapshot task: upload error: exit status 1

I tried to set the --log-level to ‘info’ to log everything when run the server - same result - no error logs.

The referenced script runs successfully when run manually.

So the question is obvious: how to control the logs verbosity for the task or before action?

Also, a question related to the snapshot+actions basics: the action is called ‘before-snapshot’ so I expected it is run prior to the snapshot but it is not. My scenario is to have a dynamically created folder (/var/lib/portainer/config_backup) which is created by the before action and removed by the after action, but Kopia fails whole snapshot because that folder doesn’t exist when the snapshot initiated. Why???