Cannot create repository on SFTP


I’ve tried 3 different servers, and 4 SFTP server softwares.
I always get the same error when trying to create the repository :

WARN unable to persist sharding parameters: unexpected error renaming file on SFTP: sftp: “Invalid parameter” (unknown)

Connect Error: INTERNAL: internal server error: connect error: unable to write blobcfg blob: PutBlob() failed for “kopia.blobcfg”: unable to complete PutBlob(kopia.blobcfg) despite 10 retries: unexpected error renaming file on SFTP: sftp: “Invalid parameter” (unknown)

The SFTP user has all the privileges on the files, so this is not the issue (confirmed with Filezilla client, which is able to perform all the kind of operations).

Same issue, whether I use the command line, or Kopia UI. All my parameters seems to be good.
I searched a long time on Google, nobody seems to have the same problem.

Where am I wrong ?

Thank you for your help.

I am having his exact same problem, but an s3 bucket.

Curiously, using the exact same s3 provider, bucket name, endpoint url and access keys through the GUI on a Windows machine works just fine, but on the linux machines I’ve tried I get the same result.

It’s gotta be a bug in the latest version (I’m at a fresh install of v0.17.0) of kopia for linux. Oh, and I’ve tried on both an arm64 instance of linux, and x86_64 instance.

So bizarre, because I had it working before, I believe even with same version, (though it would’ve been pulled from the repo a few weeks ago as opposed to this past week.