Do not validate TLS certificate do not have any effect in webui

Currently the only option is to disable TLS verification completely (–disable-tls-verification), a better solution would be to support specifying custom ca PEM file for each S3 blob provider connection. PRs to implement this are welcome.

the “Do not validate TLS certificate” option in the web-ui seems to be ignore…
is it a bug or am i missing something ?

so is there a way to activate this anywhere else , i am using the official docker image

Note : i realised after the fact i comment on github after you close so i decide to post in forum…
sorry if i am doing all wrong way…

ok tried the following and it work so definitively something with the web ui who dod not seem to use the
“Do not validate TLS certificate”

docker exec -t <container ID> /app/kopia repository connect s3 --bucket=kopia --access-key=<Key> --secret-access-key=<secret> --endpoint=<endpoint> --disable-tls-verification

so for now , i run the docker exce repo connect command from the host and then restart the container
that’s give me access to the repo…
i did a snapshot and change the policy to do a scheduling snapshot
not ideal but work for now

This is now fixed. Thanks for the report.

Thanks Jarek
i will test to report back
in which version it is fixed ?

Latest unstable or kopia-test-builds