Kopia 0.8 keeps losing my snapshots and snapshot config

I’m using the S3 backend, and backing up two systems to bucket/path locations that look like:


I did some initial tests where I cancelled snapshots part way through because I needed to add a bunch of ignore rules. but during those tests between runs it lost the ignore rules I was setting, and I had to redo them from the start every single time.

now, after completing the initial backups last night, I went to take a look today… and kopia snapshot list doesn’t show anything saved other than the base snapshot name (root@system1:/). as well, all the ignore policies I put in place for these hosts are gone.

how do I figure out what’s going on here, and get it to correctly keep its state? :sweat:

actually, on one of the systems, I ran it before and after writing this post, and now the snapshot name doesn’t even show up either. but I’ve got ~280GB of blobs in my S3 bucket. what is going on here??

[before writing this post]
root@system:~# kopia snapshot list

[after writing this post]
root@system1:~# kopia snapshot list

where are the per-snapshot policies stored? I don’t see anything in the repository config file locally, I think it would be good to know how to inspect the state of my repo and snapshots to further diagnose this behaviour. and it’d also help me restore all my ignore policies after this happens to I can continue testing. redoing them from scratch every time is becoming a huge pain.

Just to clarify… you have setup one S3 bucket and configured one repo for it, which is used by two clients, right?

Have tried to connect to that S3 repo from the clients and perform a snapshot listing? You can also run

kopia snapshot list --all to see all snapshots, even the ones not belonging to the connected user.