Remove partial snapshot files

Hi,

I ran a snapshot to a local repo.
I then played with .kopiaignore and I accidentaly included a big directory I didn’t want to backup.
I ran a snapshot immediately after and noticed my mistake.
I canceled the backup, but several Gs were already uploaded. A partial snapshot was created.
I reversed the .kopiaignore to its previous state (so that the big dir is not included anymore).
I ran kopia maintenance and then kopia maintenance --full, expecting that the files corresponding to the big dir would be removed from the repo. Having a look at the repo (I sorted the files by time), there are files that I suppose should not be there, given that I don’t think I changed anything on my system between the 2 snapshots.

Before I mess up too much with my repo, is there a way to delete the partial snapshot?

thanks

This is because of safety protocol employed during maintenance, which relies on passage of time to ensure all cached data has expired where appropriate.

You should be able to get rid of unused data quickly by:

kopia snapshot delete <snapshot-to-remove> --delete kopia maintenance --full --safety=none

NOTE: You need to absolutely ensure no other kopia processes are running during this maintenance with --safety=nonw as it can otherwise lead to repository corruption. Regular full maintenance is designed to be safe even if other kopia instances are running (possibly on other machines).

(I recommend using the latest nightly build from unstable RPM/apt channel or from https://github.com/kopia/kopia-test-builds/releases/latest for that maintenance). The same feature will be released in 0.8.0-beta5 very soon.

thank you very much. great work and outstanding support