Snaping the same file on Windows and then on linux creates 2 snaps

I use both linux (ubuntu) and windows 10 on a same device.
I store my data on a dedicated partition J: mounted with veracrypt.
On windows, I made a snap of a specific file included in J: and checked that it was properly uploaded.
On linux, i then tried to snap this exact same file.
However, kopia started from scratch and created a different new snap without considering the first one created on windows.
I have the same problem if I snap on linux first.
Could you please help me on this matter?

I use Kopia 0.9. on windows 10.
I tried both through UI and CLI

Do you mean that data was uploaded twice?

Yes, it was uploaded twice.

The title of the post is misleading, but I have the same issue.

One data partition is shared by debian and windows on the same machine, and dedup does not seem to happen. Once data have been uploaded from debian, trying a snap of the same data from windows leads to re-uploading data, possibly from scratch. My link being slow, I canceled the upload, but data was effectively being uploaded for one hour.