Cannot run maintenance as Kopia CLI believes I'm not the repository owner

I’ve changed the hosting server and have migrated the repository over with kopia snapshot move-history.

In KopiaUI this change has been reflected, but when I run kopia maintenance info the owner is the old user, and with kopia maintenance run --full, I get the following error, “ERROR maintenance must be run by designated user: x@y (old repository owner)”.

The Kopia host is Windows.

I will say that I run 0.15.0 which is an older version, but I wanted to do maintenance before I upgrade to make sure no problems arise. I could try updating first, but I really want to make sure no problems arise, as I temporarily don’t have access to any backup of the Kopia repository.

You moved snapshots ownership but maintenance is still using the old one. You can check it by running:

$ kopia maintenance info
Owner: old_user@old_host

and change by running:

$ kopia maintenance set --owner=new_user@new_host
1 Like

Thank you, works great now.