Kopia is trying to duplicate 700 GB of data on B2

I’ve been trying to upload a single 697.9 GB file to B2 for the last week as part of a larger repository. I don’t have significant upload speed so it’s been taking a while. I’ve run into the same issue twice now.

Despite the B2 repository now having all of the data uploaded and cached (it completed without errors), the snapshot still shows as “incomplete”, and when I ask Kopia to snapshot again, it starts over and tries to reupload it all from the beginning.

I’ve tried migrating from another local repository, as well as taking a snapshot directly from the source. Both try to restart the upload from the beginning, seemingly ignoring the 697.9 GB of data in the B2 bucket. I’ve tried using a new, empty bucket – same problem in the end.

  2022-12-30 16:43:35 MST k90a9225d3c8ae7b559d3286976467077 0 B drwxrwxrwx files:0 dirs:1 (latest-1)
  2023-01-04 13:12:27 MST kd996ca185de2f6dace8aa77df9d0f53d incomplete:checkpoint 4.2 TB drwxrwxrwx files:6 dirs:1 (incomplete)
  2023-01-04 13:57:32 MST k3533b63317d7bc2561ec322d25af5969 incomplete:checkpoint 2.8 TB drwxrwxrwx files:4 dirs:1 (incomplete)
  2023-01-04 14:43:08 MST kf442d3c1d97236c6c62034c9951b4132 incomplete:checkpoint 2.8 TB drwxrwxrwx files:4 dirs:1 (incomplete)
  2023-01-04 15:29:13 MST k7960d65288b0cbae8cf1b2be7b8ef297 incomplete:checkpoint 4.9 TB drwxrwxrwx files:7 dirs:1 (incomplete)
  2023-01-04 16:11:54 MST kf405a16b411048a2abd1fc9cf18f5125 incomplete:checkpoint 1.4 TB drwxrwxrwx files:2 dirs:1 (incomplete)

Does anyone have any ideas on how I can get this snapshot finalized? I’ve been using kopia for a while and haven’t had this issue before. I’m keeping it shut off for now just in case garbage collection decides all of the data is trash. Any pointers would be greatly appreciated!