Problem connection to repository

Good morning,
I am running Kopia v0.8.4 on a windows 10 laptop which backup are sent to a repository on an external USB drive connect to a Raspberry Pi 4 running OMV 5.
I switch the external USB drive every Monday and I have been doing so for the past few months. However, this past Monday, I was not able to connect to the repository on the drive. I have the following error

Connect Error: INTERNAL: internal server error: unable to list sources: unable to find manifest entries: unable to load manifest contents: error loading manifest content: getCacheForContentID: BLOB not found

I have tried rebooting the Raspberry Pi, updating it, restarting the Laptop, reinstaling Kopia, all without success.

Is there something I can do about it or do I need to delete all files and restart my backup?

Thank you


What do you mean by switching the USB drive monday? Are you saying that you’re running the same repo on multiple drives? What’s the reason for that anyway? You would end up with multiple different “versions” of the same repo on multiple drives. Also handlng of that would require to perform some housekeeping on your kopia server.

The right way of duplicating the repo on the RPi4 would be to use Kopia’s sync-to feature and have both drives attached to the RPi at the same time.

I switch the external hard drive on the RPi4 every Monday night, and I switch the repository on Kopia at the same time. This way, I am hoping to have 2 independant backup following the 3-2-1 backup philosophy. I have been operating this way for a couple of months without any problems.

Is there a better way to do the same thing? BTW I also have a Macbook Pro with time machine backing up to the RPi4 external drive, so I would prefer being able to have 2 separate backups.

Is there a way to ignore the missing blob and continue the backup from the last working blob?
What is the relation between manifest and blob?
Thank you

I still don’t get the procedure, you’re following, when doing so. And what do you mean by “switch the repository on Kopia”. I assume, that you’re running a Kopia server on the RPi. So, you’re doing it like this?

  • stop Kopia server
  • unmount/unplug the drive
  • plug in other drive/mount
  • start Kopia server with a different config
  • server a different repository
  • switch the repository on your clients

This would be way to cumbersome and error prone. What are doing with the inactive drive, are you storing it somewhere offsite? Anyway, this still doesn’t achieve a 3-2-1 backup, but that’s okay.

However, this can be easily achieved with a kopia repo sync-to which you’d run once weekly and then pit that drive away.

This depends on the version of Kopia, you’re running. The gutts of Kopia are quite complex and there’s no easy answer, without extensive logs from Kopia.

Thank you for your reply.

I only run Kopia on my Windows computer and not on the RPi4. I only configure the “Filesystem” in Windows laptop to backup to network location.

This is the procedure I follow :
1- Unmount the drive 1 from OMV5 (remove SMB, remove share folders and unmount file system)
2- Disconnect usb drive 1 from RPi4
3- Connect usb drive 2 to RPi4
4- Mount drive 2 in OMV5 (mount file system, add share folders, add SMB)
5- Change “filesystem” repository of Kopia on Windows machine to network location of drive 2
6- The unused drive at my workplace.

My thoughtprocess doing so was that I have 2 independant backup, whereas if I sync backup form one drive to the other I could propagate backup error.between backups.

What would you prpose as a more reliable way to backup my computers?

I see… so first off, you’d better shutdown Kopia on your client, to prevent it from doing maintenance on the repo, which it will always do silently in the background. Only after Kopia has shutdown remove the volume. Neglecting this, could very well cause your repo to exihibit errors, like the ones you mentioned before.

Then you can proceed with the rest. However, running the repo on a network share will come with some performance penalties and it makes your setup unnecessarily complex. I do get your reasoning behind that, but there are ways in Kopia to make this more streamlined and faster. Alas, that would need to setup a Kopie server on your RPi4 along with OMV (or even a dedicated RPi4) and I don’t know, if that’s a viable option for you.

Nonetheless, you can also use the CLI version of Kopia on your Windows host (I think) and get to the same result, without messing with your RPI4’s setup. In this case you’d connect the “backup” drive to your Windows host, just like a regular drive and run the kopia repo sync-to filesystem … on your Windows box. This would synchronize the networked repo to your local drive, which you then could just unmount and take to your workplace. No need to shutdown KopiaUI and less chances to get something mixed up.

I have been a rather “longtime” Kopia user and I can assure your, there’s almost nothing, that you can do that will increase the robustness of Kopia by adding more layers of complexity to your process.

Thank you very much for your help.

I think I will start a new backup of the one drive that does not work. How should I proceed? Only delete all the files from the drive?

then I wil shutdown Kopia UI on Windows everytime I switch the drive.

thank you again!

Do you have two repos configured in KopiaUI? If yes, you’d have to delete the one for the drive you want to create a new repo on - well, at least if the drive isn’t big enough to hold two repos, that is.

Then you can go ahead and remove all the repo contents from the drive and create a new repo on it.

Running Kopia close to the drive capacity limit is very risky and was not extensively tested, in case writes fail, Kopia should fail safely but recovering from this situation may not be easy. This is because direct deletion of blobs is not going to be possible to release disk space since blobs contain different contents (mix of used and unused) and a rewrite operation is needed before garbage collection.