Problem enabling actions on server

I have a kopia server backing up some of its files. I want to enable actions but after reading [Actions | Kopia] (and, I haven’t been able to make it work.

I launch kopia server as root with systemd:

execStart=/usr/bin/kopia server start --enable-actions --tls-cert-file /opt/kopia/my.cert --tls-key-file /opt/kopia/my.key --address --cache-directory=/var/cache/kopia --server-username=kopia@servidor7 --log-file=/var/log/kopia.log --log-dir="/var/log/kopia"

Then I enter the web ui with admin user and launch the backup from there, but I get

Not executing before-folder action on /backup because it's been disabled for this client.

I have multiple repository.config, but none of them have a enableActions option:


Which of them should I edit? and enableActions should be a root level parameter?

Based on the command line you’ve shown, it looks like you probably want to edit the repository config in /opt/kopia, assuming that is where your current backup policy is. And yes, enableActions is a top-level configuration option.

Thanks, it’s working now.