Resume a backup from another computer


Is it possible to :

  • copy a directory dir1 from system1 to an external hard drive
  • “kopia create snapshot” online on repo1 from system2
  • continue “kopia create snapshot” of dir1 on repo1 from system1

I have access to a fast internet connection which is pretty rare for me. I thought I could speed up the process of the initial backup.


That should just work. Second snapshot should not upload anything since it deduplicates every file.

1 Like

It’s working great.

Is there a way to change the user responsible for the maintenance? The initial backup was not created by the usual user.



Kopia maintenance set —owner=me

should do the trick.

It worked. But:

All the snapshots listed with ‘kopia snapshot list’ show an error. And no maintenance --full can complete.

Here is what I did:

I uploaded the initial backup from an external hard drive on a debian machine to b2, running kopia 0.8.1 or 0.8.2. During the upload, I got the error:
error refreshing repository: error refreshing content index: error listing index blobs: error listing indexes: error listing n blobs: error listing blobs: error listing all blobs: Post "": EOF
I cancelled the upload with <CTRL+c>, and resumed the upload the next day. It completed smoothly. No error was listed on the single created snapshot listed with ‘kopia snapshot list’.

Few days after, I connected to the repo using kopia-ui on windows. The snapshot found on the repo showed an error and no maintenance was possible. From the command line, I used ‘Kopia maintenance set —owner=me’ as you suggested to be able to run the maintenance.

edit: Correction: I did not see the initial snapshot on windows. The one showing an error was the first one I could create from the ui on windows.

I tried to take a few snapshots from the ui and the command line and got some errors such as:
unable to remove unused index file: remove C:\Users\Antoine\AppData\Local\kopia\2789c7b9ab36d615\indexes\n3486d8d35d9289881c0baebd7db58a62.sndx: with a permission denied warning, and:
Rewriting contents from short packs... unable to rewrite content "0828897564bc0dc786400aee48bc6db6": unable to write pack: error writing pack: can't save pack data blob peda8d1138a8951f742aa5c2cdc02aa6f-sfefa666418ab3674103: unable to complete PutBlob(peda8d1138a8951f742aa5c2cdc02aa6f-sfefa666418ab3674103) despite 10 retries when running maintenance --full

Coming back to the linux machine and listing the snapshots, I can only see the initial one and still no error is displayed.

Is there a way to try to fix this, given that I can’t re-upload everything ?

Thanks a lot